watterott ;title =
Ergebnis 1 bis 3 von 3

Thema: DFC77 Problem

  1. #1
    Neuer Benutzer
    Registriert seit
    28.10.2012
    Beiträge
    25

    DFC77 Problem

    Hallo zusammen
    DFC77 führt mich ganz schön an der Nase herum.
    Nach einigen paar Stunden habe ich gepeilt, dass mein Zeitsignal aus dem Conrad Mudul prellt.
    Mit einer sep. Stromversorgung habe ich dieses Problem behoben, so dass die Software zum Tragen kommt.
    Ich habe mir da etwas vom Internet gezogen und etwas modifiziert.
    Das org. war mit einem 328'er mir 16 MHz getaktet.
    Ich verwende nun ein M32A mit 8MHz und habe ein anderes Display eingebunden.

    An der Led habe ich nun ein sauberes Sekunden Zeitsignal.
    Parallel dazu läuft die Uhr auf den Display, welche den Takt vorerst vom Prozessor erhält.

    Was man deutlich sehen kann, ist, dass das Display deutlich langsamer als der Takt der LED ist.
    Grob würde ich sagen 1.5-2 mal langsamer.
    Da sich nun die Zeit auch nach Minuten nicht automatisch nach DFC77 stellt, habe ich die Vermutung,
    dass auch die Auswertung des Bitmusters nicht richtig abgearbeitet wird, weil dies mit dem Systemtakt offenbar nicht passt.

    Ich habe nirgendwo einen richtigen Hinweis gefunden, wie die Taktrate des Prozessors, mit der Lib von DFC77 zusammenhängt.
    Kann das daran liegen, wie ich vermute, oder bin ich da auf dem Holzweg?

    Für einen Hinweis wäre ich euch dankbar.

    Gruss Kuno
    Angehängte Dateien Angehängte Dateien

  2. #2
    Code-Guru Avatar von Michael
    Registriert seit
    05.01.2008
    Ort
    Karlstadt
    Alter
    47
    Beiträge
    6.251
    Grob würde ich sagen 1.5-2 mal langsamer.
    also statt 8MHz läuft der Prozessor auf 4-6MHz.
    Prüf doch mal die Fuse-Einstellung der Taktfrequenz.

    Hintergrund:
    Wenn der Controller nur halb so schnell läuft, wie angegeben, dann erwartet die DCF-Routine Pulse von 200 oder 400 ms.
    Pulse mit 400ms kommen aber nicht, das Telegramm wird nicht korrekt decodiert.

    Gruß, Michael

  3. #3
    Neuer Benutzer
    Registriert seit
    28.10.2012
    Beiträge
    25
    Hallo Michael

    Danke für die schnelle und vor allem richtige Antwort!
    Es hat genau daran gelegen!

    Gruss Bonzo

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Ab 20 € Spende kann man das bascom-tutorial runterladen.